[vlc-devel] [PATCH 0/5] cpp: renaming all *sys_t because of ODR

Rémi Denis-Courmont remi at remlab.net
Wed Mar 7 17:42:25 CET 2018

Le keskiviikkona 7. maaliskuuta 2018, 18.31.54 EET Thomas Guillem a écrit :
> Hi,
> After loosing some times in a memory corruption on vlc-ios because VLC
> violates the One Definition Rule, I started to rename all *sys_t in all cpp
> modules. (spatialaudio filter_sys_t was used from the blend module)
> If you agree with my naming convention and everything, I'll continue and fix
> all others cpp modules.
> The sys_t renaming will need to be backported to 3.0.
> Then, in 4.0, we can remove all *sys_t typedef and replace it with void*. Do
> you agree ?

I think that sort of revectoring is a big no-no w.r.t. backporting.

Don't enable whatever optimization this breaks. Typically, this would be 
mostly down to LTO or RTTI.


More information about the vlc-devel mailing list