[vlc-devel] [PATCH V2 11/13] test: player: add audio_block_length param
Thomas Guillem
thomas at gllm.fr
Mon Aug 26 17:07:28 CEST 2019
On Mon, Aug 26, 2019, at 17:00, Alexandre Janniaux wrote:
> Hi,
>
> LGTM, this one and the seconde one might be merged separately imho.
> Would audio_sample_length be a better name than audio_block_length?
Yes.
>
> Regards,
> --
> Alexandre Janniaux
> VideoLabs
>
> On Fri, Aug 23, 2019 at 04:45:16PM +0200, Thomas Guillem wrote:
> > ---
> > test/src/player/player.c | 11 +++++++----
> > 1 file changed, 7 insertions(+), 4 deletions(-)
> >
> > diff --git a/test/src/player/player.c b/test/src/player/player.c
> > index de916e7a8a..ba9eba57bf 100644
> > --- a/test/src/player/player.c
> > +++ b/test/src/player/player.c
> > @@ -142,6 +142,7 @@ REPORT_LIST
> > struct media_params
> > {
> > vlc_tick_t length;
> > + vlc_tick_t audio_block_length;
> > size_t track_count[DATA_ES];
> > size_t program_count;
> >
> > @@ -158,6 +159,7 @@ struct media_params
> >
> > #define DEFAULT_MEDIA_PARAMS(param_length) { \
> > .length = param_length, \
> > + .audio_block_length = VLC_TICK_FROM_MS(100), \
> > .track_count = { \
> > [VIDEO_ES] = 1, \
> > [AUDIO_ES] = 1, \
> > @@ -627,14 +629,15 @@ create_mock_media(const char *name, const struct media_params *params)
> > int ret = asprintf(&url,
> > "mock://video_track_count=%zu;audio_track_count=%zu;sub_track_count=%zu;"
> > "program_count=%zu;video_packetized=%d;audio_packetized=%d;"
> > - "sub_packetized=%d;length=%"PRId64";title_count=%zu;chapter_count=%zu;"
> > + "sub_packetized=%d;length=%"PRId64";audio_block_length=%"PRId64";"
> > + "title_count=%zu;chapter_count=%zu;"
> > "can_seek=%d;can_pause=%d;error=%d;null_names=%d",
> > params->track_count[VIDEO_ES], params->track_count[AUDIO_ES],
> > params->track_count[SPU_ES], params->program_count,
> > params->video_packetized, params->audio_packetized,
> > - params->sub_packetized, params->length, params->title_count,
> > - params->chapter_count, params->can_seek, params->can_pause,
> > - params->error, params->null_names);
> > + params->sub_packetized, params->length, params->audio_block_length,
> > + params->title_count, params->chapter_count, params->can_seek,
> > + params->can_pause, params->error, params->null_names);
> > assert(ret != -1);
> >
> > input_item_t *item = input_item_New(url, name);
> > --
> > 2.20.1
> >
> > _______________________________________________
> > vlc-devel mailing list
> > To unsubscribe or modify your subscription options:
> > https://mailman.videolan.org/listinfo/vlc-devel
> _______________________________________________
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
> https://mailman.videolan.org/listinfo/vlc-devel
More information about the vlc-devel
mailing list