[vlc-devel] [PATCH 3/4] vdpau: add a helper function to get the vdp_t from the decoder device
Alexandre Janniaux
ajanni at videolabs.io
Mon Oct 21 08:58:06 CEST 2019
Hi,
Shouldn't we use the vdpau decoder device only when it is
a VLC_DECODER_DEVICE_VDPAU ? Meaning it should be an assert
instead of a check.
Regards,
--
Alexandre Janniaux
Videolabs
On Mon, Oct 21, 2019 at 08:45:38AM +0200, Steve Lhomme wrote:
> ---
> modules/hw/vdpau/vlc_vdpau.h | 8 ++++++++
> 1 file changed, 8 insertions(+)
>
> diff --git a/modules/hw/vdpau/vlc_vdpau.h b/modules/hw/vdpau/vlc_vdpau.h
> index d0e8bde787e..ba5d1443bf0 100644
> --- a/modules/hw/vdpau/vlc_vdpau.h
> +++ b/modules/hw/vdpau/vlc_vdpau.h
> @@ -21,6 +21,7 @@
> #ifndef VLC_VDPAU_H
> # include <stdint.h>
> # include <vdpau/vdpau.h>
> +#include <vlc_codec.h>
>
> typedef struct vdp_s vdp_t;
>
> @@ -274,6 +275,13 @@ typedef struct vlc_vdp_video_field
> float sharpen;
> } vlc_vdp_video_field_t;
>
> +static inline vdp_t *GetVDPAUOpaqueDevice(vlc_decoder_device *device)
> +{
> + if (device == NULL || device->type != VLC_DECODER_DEVICE_VDPAU)
> + return NULL;
> + return device->opaque;
> +}
> +
> /**
> * Attaches a VDPAU video surface as context of a VLC picture.
> */
> --
> 2.17.1
>
> _______________________________________________
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
> https://mailman.videolan.org/listinfo/vlc-devel
More information about the vlc-devel
mailing list