[vlc-devel] [PATCH v2 1/3] Re-implemented SoutMrl in a more object-oriented way
ajanni at videolabs.io
Mon Oct 21 23:43:40 CEST 2019
Sorry for late answer. I believe a correct name would be SoutChain or
StreamOutputChain, by refering to the `vlc -H` output.
> Stream output
> These options allow you to set default global options for the stream output subsystem.
> --sout <string> Default stream output chain
> You can enter here a default stream output chain. Refer to the
> documentation to learn how to build such chains. Warning: this chain
> will be enabled for all streams.
I hope it helps,
On Mon, Oct 21, 2019 at 08:56:31AM +0200, Jérôme Froissart wrote:
> Sorry Rémi, I'm sending this question again. I'm not sure if I should add
> you explicitly in the recipients...
> On Thu, 17 Oct 2019, 17:47 Rémi Denis-Courmont, <remi at remlab.net> wrote:
> > Le torstaina 17. lokakuuta 2019, 18.11.24 EEST Jérôme Froissart a écrit :
> > > ---
> > > AUTHORS | 1 +
> > > modules/gui/qt/Makefile.am | 1 +
> > > .../qt/components/sout/profile_selector.cpp | 2 +-
> > > .../gui/qt/components/sout/sout_widgets.cpp | 1 +
> > > modules/gui/qt/dialogs/sout.hpp | 71 +---------
> > > modules/gui/qt/util/soutmrl.cpp | 108 ++++++++++++++
> > > modules/gui/qt/util/soutmrl.hpp | 133 ++++++++++++++++++
> > > 7 files changed, 246 insertions(+), 71 deletions(-)
> > > create mode 100644 modules/gui/qt/util/soutmrl.cpp
> > > create mode 100644 modules/gui/qt/util/soutmrl.hpp
> > AFAICT, this is uses very wrong and confusing naming. MRL means media
> > resource
> > locator, it's more or less the VLC word for URL. This does not seem to be
> > what
> > you're working on here.
> We'll I'm just re-implementing something that was already called soutmrl.
> But we could as well rename it if you think that would be useful. Do you
> suggest any better-suited name?
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
More information about the vlc-devel