[x264-devel] Solaris 10 sparc patch to configure

Robinson, Greg greg.robinson at dsto.defence.gov.au
Tue Jan 27 02:09:15 CET 2009

Hi all,

Sorry for my late reply.  Firstly, a big thank you to all who replied.

I have tried everyones suggestions with the latest snapshot.  The
breakthrough came from replacing /bin/sh with /bin/bash in configure
and version.sh.  And from using /usr/xpg4/bin/grep, as suggested.
This fixed the creation of config.h and allowed the compile to continue.

Could I suggest that /bin/sh be replaced with /bin/bash?

I'd still like my other suggestions to be incorporated.  I'll try and
the issues raised below:

1. echo
I think when the configure script is run, it uses the shells builtin
echo command (which works), but when make is run, it uses /bin/echo,
which is broken on solaris.  Printf works, as well as echo \c.

2. AS= needs to be defined on solaris, as the final link of libx264.so
libx264.a need common/sparc/pixel.o.  I tried with --disable-asm and the
compile stops at pixel.o.

Thankx for everyones help,


IMPORTANT: This email remains the property of the Australian Defence Organisation and is subject to the jurisdiction of section 70 of the CRIMES ACT 1914.  If you have received this email in error, you are requested to contact the sender and delete the email.

More information about the x264-devel mailing list