[x264-devel] commit: Use enums instead of magic numbers in x264_mb_partition_pixel_table ( Henrik Gramner )
git at videolan.org
git at videolan.org
Fri Nov 19 23:50:10 CET 2010
x264 | branch: master | Henrik Gramner <hengar-6 at student.ltu.se> | Tue Nov 16 21:23:12 2010 +0100| [a9d7826a63f44379ef37e2a5147105c400370cd5] | committer: Jason Garrett-Glaser
Use enums instead of magic numbers in x264_mb_partition_pixel_table
> http://git.videolan.org/gitweb.cgi/x264.git/?a=commit;h=a9d7826a63f44379ef37e2a5147105c400370cd5
---
common/macroblock.h | 6 +++++-
1 files changed, 5 insertions(+), 1 deletions(-)
diff --git a/common/macroblock.h b/common/macroblock.h
index aa41ab6..b22b9b9 100644
--- a/common/macroblock.h
+++ b/common/macroblock.h
@@ -170,7 +170,11 @@ static const uint8_t x264_mb_partition_count_table[17] =
};
static const uint8_t x264_mb_partition_pixel_table[17] =
{
- 6, 4, 5, 3, 6, 4, 5, 3, 6, 4, 5, 3, 3, 3, 1, 2, 0
+ PIXEL_4x4, PIXEL_8x4, PIXEL_4x8, PIXEL_8x8, /* D_L0_* */
+ PIXEL_4x4, PIXEL_8x4, PIXEL_4x8, PIXEL_8x8, /* D_L1_* */
+ PIXEL_4x4, PIXEL_8x4, PIXEL_4x8, PIXEL_8x8, /* D_BI_* */
+ PIXEL_8x8, /* D_DIRECT_8x8 */
+ PIXEL_8x8, PIXEL_16x8, PIXEL_8x16, PIXEL_16x16, /* 8x8 .. 16x16 */
};
/* zigzags are transposed with respect to the tables in the standard */
More information about the x264-devel
mailing list