[x264-devel] [PATCH 1/2] x86inc: Rename "program_name" to "private_prefix"

Diego Biurrun diego at biurrun.de
Thu Jan 17 17:04:51 CET 2013


The new name is more descriptive and will allow defining a separate
public prefix for externally visible library symbols.

Signed-off-by: Diego Biurrun <diego at biurrun.de>
---
 common/x86/x86inc.asm |   10 +++++-----
 1 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/x86/x86inc.asm b/common/x86/x86inc.asm
index f45bdb4..88676db 100644
--- a/common/x86/x86inc.asm
+++ b/common/x86/x86inc.asm
@@ -34,8 +34,8 @@
 ; as this feature might be useful for others as well.  Send patches or ideas
 ; to x264-devel at videolan.org .
 
-%ifndef program_name
-    %define program_name x264
+%ifndef private_prefix
+    %define private_prefix x264
 %endif
 
 %define WIN64  0
@@ -650,7 +650,7 @@ BRANCH_INSTR jz, je, jnz, jne, jl, jle, jnl, jnle, jg, jge, jng, jnge, ja, jae,
 %endmacro
 %macro cglobal_internal 1-2+
     %ifndef cglobaled_%1
-        %xdefine %1 mangle(program_name %+ _ %+ %1)
+        %xdefine %1 mangle(private_prefix %+ _ %+ %1)
         %xdefine %1.skip_prologue %1 %+ .skip_prologue
         CAT_XDEFINE cglobaled_, %1, 1
     %endif
@@ -674,7 +674,7 @@ BRANCH_INSTR jz, je, jnz, jne, jl, jle, jnl, jnle, jg, jge, jng, jnge, ja, jae,
 %endmacro
 
 %macro cextern 1
-    %xdefine %1 mangle(program_name %+ _ %+ %1)
+    %xdefine %1 mangle(private_prefix %+ _ %+ %1)
     CAT_XDEFINE cglobaled_, %1, 1
     extern %1
 %endmacro
@@ -687,7 +687,7 @@ BRANCH_INSTR jz, je, jnz, jne, jl, jle, jnl, jnle, jg, jge, jng, jnge, ja, jae,
 %endmacro
 
 %macro const 2+
-    %xdefine %1 mangle(program_name %+ _ %+ %1)
+    %xdefine %1 mangle(private_prefix %+ _ %+ %1)
     global %1
     %1: %2
 %endmacro
-- 
1.7.1



More information about the x264-devel mailing list