[Android] [PATCH] MainActivity, VideoGrid, AudioBrowser, Directories, & History: focus related functional improvements

Mik Amchislavsky hailmikhail at gmail.com
Tue Oct 14 14:15:26 CEST 2014


Hi Edward,

Thanks for writing; your request encouraged me to review the patch further
and find room for improvement. Previously, I incorrectly assumed
android.R.id.list views lacked a resource definitions to house nextFocus
attributes. Now, I see these views defined as layouts.

>>> _one_ commit per change

At a minimum, I'll move nextFocus attribute initalization into a separate
patch that affects resource files instead of source.

I could have made the subject clearer. Aside from nextFocus attribute
initialization, the code dynamically updates nextFocus attributes to match
fragment selection.

Should I split up this patch into multiple chunks with one per fragment ?

Do you prefer resource and source changes together ?

Once I hear back from you, I'll resubmit this patch. Would you let me know
if you require the same done for any of the other patches, I sent this
weekend ?

>>> use more descriptive function names. (e.g. what does "focusHelper"
do?)

In this case, focusHelper serves as a wrapper for setMenuFocusDown and
setSearchAsFocusDown. For me, this wrapper makes the code easier to read.
Which of the following would you consider an improvement or would you
recommend another name ?

setNextFocuses
setNextFocusForPersistentViews

Regards,

Mik
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/android/attachments/20141014/cb4ddd44/attachment.html>


More information about the Android mailing list