[RFC] new build configuration scheme

Gildas Bazin gbazin at netcourrier.com
Thu Aug 29 19:16:47 CEST 2002

On Thursday 29 August 2002 15:51, Samuel Hocevar wrote:
> ...
> I'm not very pleased by
> the current format, mostly because the full path to the module needs to
> be specified. I considered returning to the old naming scheme, where two
> modules couldn't have the same name, but that leaves us with problems
> such as "sdl.c" which is both in the audio_output and the video_output
> directories. What do you think? Should we name the plugins "aout_sdl.so"
> and "vout_sdl.so"? I must admit this could make our lives easier.
>    The config file would then become:
> plugin x11 aa
> plugin vout_sdl
> builtin xvideo
> disable ggi
> plugin aout_sdl
> builtin oss
> disable alsa arts

Well, why not just rule out the possibility for the user to compile only 
parts of the composite plugins like sdl. We should simply allow them to be 
compiled entirely or not at all. And anyway, it shouldn't be too annoying 
as it's the way it's be done until now.


This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://www.videolan.org/lists.html
If you are in trouble, please contact <postmaster at videolan.org>

More information about the vlc-devel mailing list