[vlc-devel] Re: Problem compiing vlc SVN on Fedora Core 2

R. Bernstein rocky at panix.com
Sun Aug 22 18:31:30 CEST 2004

Gildas Bazin writes (out of order):

 [release readiiness]
 > I think the only other broken plugins are the vcdx and cddax ones 

Actually, what got me onto this was trying to fix the breakage in the
ogt and cvd subtitles. So add those two the list. The test example I
tried was one mentioned in the past:


The above link is down, and it is unclear whether it will be
reinstated soon. So I've put it temporarily in

I hope someone can copy it to a videolan-centric test area if there is
one. I tried removing the ogt module libsvcdsub_plugin.so but that
didn't help. I get:

  Xlib: unexpected async reply (sequence 0xfb7)!
  [00000204] main decoder error: no suitable decoder module for fourcc `ogt '.
  VLC probably does not support this sound or video format.

 > but to be 
 > honest they are not release critical as we have the basic vcd and cdda 
 > versions working. 

That's why I started on the ogt and cvd plugins ;-)

 > As much as I would like to have them working as well, I 
 > just don't have the time to work on them... so I can only hope you'll have 
 > a go at fixing them.

Things have been a little chaotic for me. There are a number of things
needing fixing - like how to just build vlc :-) Actually, I can now do
that thanks to your help. So I'll look at when I get a chance. 

One of the things I'm working on is another release for libcdio, and
the next release will add CD-Text support, at least on most
OS's. Darwin remains difficult. So probably the libcdio cdda plugin
fixup will be done in conjunction to adding CD-Text support. (It's
there already in the libcdio xine cdda plugin.) Seems a pity to work
on cdda to basically get to the same place as before. May as well add
something new that's been missing.

I'm also waiting for a patch to be accepted to libmusicbrainz so that
it could be used in a cdda plugin. The xine non-libcdio plugin which
has musicbrainz support seems to cut-and paste from the libmusicbrainz
library. Depending on whether my patch or something similar gets in,
musicbrainz support will be added to the libcdio cdda plugin.

 [core dump on starting vlc with incompatible old modules]
 > The trick in this case will be to do a "toolbox --distclean", which will 
 > actually recurse in all the subdirectories.

Okay thanks for the info. If there is a documentation location for
this kind of useful info (what a developer might need to know about
working with vlc) let me know and I'll add it.

 > Another tip is that you don't necessarily have to "make install" vlc to use 
 > it, you can run it directly from its source tree ...

Actually, after removing the old plugins I was getting core dumps when
run from the source tree. Perhaps it's because I didn't do the
"toolbox --distclean".  On my 1GHZ athlon box it takes something like
20 minutes to build vlc, so this is not something I enjoy doing. 

 > Don't know if the crash comes from the skins plugin or not but at least it 
 > seems that you didn't enable the wxwindows interface, which I would 
 > recommend to do.

Yep. I fixed that sometime between my last post and your reply. I've
since remade vlc with wx. And although things are at least more
familiar now, alas I can't say that things by in large work any
better. I mentioned the problems not so much as disparaging remarks so
much as things seem broken and I don't know which of the error
messages are the ones that are relevant. 

A small thing I've noticed is that although I can start svlc and wxvlc
okay, if I start wxvlc and then try to switch to the skinned version I
get a core dump. Here is a traceback. 

(gdb) where
#0  0x045389a5 in wxObject::UnRef () from /usr/lib/libwx_gtk-2.4.so.0
#1  0x0443430a in wxColour::~wxColour () from /usr/lib/libwx_gtk-2.4.so.0
#2  0x04584a5d in wxWindowBase::InitBase () from /usr/lib/libwx_gtk-2.4.so.0
#3  0x0458959e in wxWindowBase::wxWindowBase ()
   from /usr/lib/libwx_gtk-2.4.so.0
#4  0x04482dcb in wxWindow::wxWindow () from /usr/lib/libwx_gtk-2.4.so.0
#5  0x04437932 in wxControl::wxControl () from /usr/lib/libwx_gtk-2.4.so.0
#6  0x01427707 in Messages (this=0x8508840, _p_intf=0xffffff9b, p_parent=0xbb)
    at button.h:47
#7  0x013ee9d3 in DialogsProvider (this=0x8506fa8, _p_intf=0x85279e0, 
    p_parent=0x0) at dialogs.cpp:154
#8  0x013ee3d0 in CreateDialogsProvider (p_intf=0xbb, p_parent=0xbb)
    at dialogs.cpp:129
#9  0x013dcc29 in Instance::OnInit (this=0x84cbd58) at wxwindows.cpp:308
#10 0x04429828 in wxEntry () from /usr/lib/libwx_gtk-2.4.so.0
#11 0x013dc926 in Init (p_intf=0xbb) at wxwindows.cpp:253
#12 0x006c898c in start_thread () from /lib/tls/libpthread.so.0
#13 0x001cc16a in clone () from /lib/tls/libc.so.6

For me this is not critical -- I just won't do the switching. 

   [freetype message]
 > Well this is not a major breakage anyway, only the "auto-sizing" option of 
 > the freetype subtitles is broken. The message was just put there so I don't 
 > forget to fix it before the release ;)

Okay. Again, since I don't know what's causing my problem I wasn't
sure if this was it or not. Ditto for the reduce_mousever.png, but
thanks for fixing. 

This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html
If you are in trouble, please contact <postmaster at videolan.org>

More information about the vlc-devel mailing list