[vlc-devel] Broadcasting/multicasting a DVB transponder signal

Marius Kjeldahl marius at kjeldahl.net
Thu Dec 30 22:30:55 CET 2004

I'm grabbing signals from a Twinham DVB card from a satellite feed, and 
it works mostly ok, except that the linux drivers are a bit unstable 
(sometimes the frontend driver does not load properly and have to be 
reloaded and it sometimes have to be rmmod/insmod'ed after use).

I have verified that I get the signals ok from the card by using 
commands such as:

$ ./vlc -vvvv dvb: --program 1501 --dvb-frequency 12322000 --dvb-srate 
27800000 --dvb-adapter 0 --dvb-modulation 32 --dvb-voltage 18

which displays the stream from the dvb card just fine. Next I wanted to 
take all the channels (or at least a few) from the same transponder and 
multicast it out on the lan. That is (still) a challenge.

Searching the mailing lists, I found a series of posts with the subject 
"multicasting full transponder" or something like that, and I used that 
to create the following test:

$ ./vlc -vvvv dvb: --dvb-frequency 12322000 --dvb-srate 27800000 
--dvb-adapter 0 --dvb-modulation 32 --dvb-voltage 18 --dvb-budget-mode 
--sout-all --ts-es-id-pid --ts-silent --intf dummy --sout \

What I'm trying to do is to take two programs from the same transponder 
(1501 and 1502 - I have verified they display fine individually) and 
have vlc send it on the network using udp and with portnumbers matching 
the program.

I've tried quite a few "tweaks" to get this working, but have not been 
successful so far. Do anybody see any obvious mistakes?

I've also tried replacing access=udp with access=file and a filename in 
the url to rule out network stuff, but the files get no data either 
(zero size).

I am not sure whether the "broadcast all channels in a transponder" is 
actually supposed to work, but posts I've read from this board in the 
past indicates that it should.

In case anybody reads this in the future, the modules that need to be 
loaded to get the Twinhan DST cards up and running are:

bttv i2c_hw=1

Verify that a device like /dev/dvb/adapter0/frontend0 exists after 
loading the drivers. If it does not, try rmmod and reload the drivers. 
The frontend device should usually appear after a couple of tries. I'm 
using devfs and have no idea how to verify that the frontend0 device 
exists if you are not.

Thanks for any help.


Marius K.

This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html

More information about the vlc-devel mailing list