[vlc-devel] libcddax_plugin.so: undefined symbol: cdio_paranoia_modeset

C.Y.M cym at syphir.sytes.net
Sun Jan 30 06:17:14 CET 2005

R. Bernstein wrote:
> Because this may be a general problem for others, I'd be interested to
> know how you got in this state. 
> 1. Was configure regnerated and rerun?  (My guess is not)

Yes, configure was executed beforehand.

> 2. If you ran configure did you add the option --enable-cddax? In
>    contrast to before, default is *not* to build cddax or vcdx by
>    default and I'd be interested to know if this is not working.

The default is to enable.  From ./configure --help:

--enable-cddax          CDDAX plugin support (default enabled)

I just solved the problem by disabling cddax for now.  I want to keep up with 
all the fixes and not have that hold me back.

> My current guess is that probably configure didn't get recreated and
> rerun. Was it? If not:
> 1.  I've seen this happen a bit before when plugins have gotten
>     added/removed/moved. Gildas may have once suggested how to deal
>     with this situation in response to my call for help and no doubt
>     that's somewhere in the devel archives.
> 2.  If you can't find what to do in devel archives or whatever that is
>     doesn't work (and configure wasn't recreated/rerun on its own) try
>     running from vlc-trunk:
>        autoconf
>        ./configure --enable-cddax ...
> 3.  If 2 doesn't work there is always running ./bootstrap or even erasing 
>     the tree, checking out again staring out from scratch.

I have tried all of the above.  There is just something that changed with that 
last checkin to /trunk/modules/access/cdda/access.c.

BTW, sorry for those extra responses.  I had used the wrong account on accident.

Best Regards,

This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html

More information about the vlc-devel mailing list