[vlc-devel] Re: S/PDIF & nforce issue

Mark Lehrer mark at knm.org
Mon Aug 21 15:31:00 CEST 2006

On Mon, Aug 21, 2006 at 08:37:58AM +0200, Sigmund Augdal Helberg wrote:
> > VLC media player 0.8.4 Janus
> > [00000311] a52 decoder: A/52 channels:6 samplerate:48000 bitrate:448000
> > [00000314] alsa audio output error: internal: can't find audio-device (10)
> > [00000314] oss audio output error: cannot reset OSS audio device
> > 
> > I set hw:0,1 to be the device in the VLC config screen (card 0: NVidia
> > [HDA NVidia], device 1: AD198x Digital [AD198x Digital])
> spdif is working just fine for me with nforce audio and alsa. I do
> however set --alsadev to something else than hw:0,1. Using the wxwidgets
> gui you can go to preferences/audio output/alsa. There should be a
> "refresh" button next to the alsadev option and pressing this should

The gui lets me choose hw:0,0 for analog and hw:0,1 for digital.  The
string is AD198x instead of iec958.

aplay -L | grep -i iec958 gives me this result though:
iec958 'cards.pcm.iec958'
spdif 'cards.pcm.iec958'

> with 'IEC958' in the string. Also be aware that your vlc version is
> somewhat old. Ideally we should be able to browse and select correct
> audio device when user asks for spdif, but no one has stepped up to
> write this code yet.

I tried 0.8.5 and I got a different error about a buffer underrun, but
the same result over S/PDIF - no sound.

There is a readme included with mplayer, hwac3.txt, containing a lot
of documentation on how they made S/PDIF work, I'm going to start
looking at that.  Something about changing AFMT_AC3 channels=1 to
AFMT_S16_LE channels=2 and a non-audio bit somewhere... I am still
a newb at some of this!


This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html

More information about the vlc-devel mailing list