[vlc-devel] Re: vlc does not play streaming (liveMedia).

Ross Finlayson finlayson at live555.com
Fri Mar 31 09:56:52 CEST 2006

>I've installed VLC on a Zaurus SL-C3100 with liveMedia for streaming
>In a machine I run a streaming server and in my Zaurus, with VLC I run
>vlc rtsp://MyIP/Session.
>All the rtsp traffic is made, The client open a socket UDP in a port
>determined in the session. Testing with netstat I see that it received
>the RTP traffic in this port. But VLC does not call the function
>StreamRead in any moment.

Those symptoms suggest that perhaps "select()" might not be working 
properly on your Zaurus.  I suggest checking whether the function 
"MultiFramedRTPSource::networkReadHandler()" (in 
"liveMedia/MultiFramedRTPSource.cpp") ever gets called.  If it 
doesn't - and you're sure that you really do have incoming RTP 
packets - then check whether the call to "select()" in 
"BasicUsageEnvironment/BasicTaskScheduler.cpp" ever returns a value > 
0.  If it doesn't, then this suggests that "select()" is not working 
properly, and there is something wrong with your port of the LIVE555 
Streaming Media code.

You might also try running the "openRTSP" command-line RTSP client; 
this includes only LIVE555 code.

	Ross Finlayson
	Live Networks, Inc. (LIVE555.COM)

This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html

More information about the vlc-devel mailing list