[vlc-devel] Re: Trying to make a Fink package (Mac machine)

Pierre d'Herbemont pdherbemont at free.fr
Tue May 8 22:15:53 CEST 2007

On 8 mai 07, at 21:14, lavigne at getphuture.com wrote:
> Thanks Pierre, it worked well to pass the compile step. Anyway now  
> I got some troubles at the install step. I got the following error  
> while making install to the fink directory :
> test -z "" || mkdir -p -- . "/sw/src/fink.build/root-vlc-0.8.5-1"
> test -z "/sw/bin" || mkdir -p -- . "/sw/src/fink.build/root- 
> vlc-0.8.5-1/sw/bin"
> /sw/bin/ginstall -c -m 644 './VLC.app' '/sw/src/fink.build/root- 
> vlc-0.8.5-1/sw/bin/VLC.app'
> /sw/bin/ginstall: omitting directory `./VLC.app'
> make[3]: *** [install-vlc_appDATA] Error 1
> make[2]: *** [install-am] Error 2
> make[1]: *** [install-recursive] Error 1
> make: *** [install] Error 2
> ### execution of /var/tmp/tmp.1.mZxWup failed, exit code 2
> I tried some stuffs, like manually creating the repository or with  
> the simple use of install -d, still the same return. I'd like to  
> know if VLC is using a kind of special feature 'cause it may come  
> from the Fink tools too.

You should here try to hack vlc/Makefile.am to remove the creation of  
the VLC.app bundle. I think you don't want it. The best thing would  
be to add a configure switch to build VLC.app from vlc bin, and send  
a patch to the vlc-devel. If you encounter too much troubles, I could  
give it a try myself.


This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html

More information about the vlc-devel mailing list