[vlc-devel] trouble building vlc on leopard intel os x

Andi Vajda vajda at osafoundation.org
Sat Nov 10 22:20:05 CET 2007

On Sat, 10 Nov 2007, Pierre d'Herbemont wrote:

> This is an ld64 bug. This one might be fixed in next Xcode release
> depending on Apple engineering team.
> For the mean time I may commit some assembler fix. An other solution
> would be to use the Mac OS X 10.4u SDK, with the old ld_classic. But I
> can't get that solution to work properly.

  Hi Pierre,

I tried the build again after getting the latest from svn. I rebuilt the 
contribs and the libtheora problem is resolved.

I re-ran configure and 'make clean' in the main build and saw that configure 
was now assuming '--disable-mmx' and '--disable-sse' but the main build still 
fails with the same error.
You mention 'ld64' but, as far as I know, I'm not doing a 64-bit build and the 
error message I reported is about 'ld'. I could be confused, of course.

   gcc -std=gnu99  -o .libs/libffmpeg_plugin.dylib -bundle
   .libs/libffmpeg_plugin_la-ffmpeg.o .libs/libffmpeg_plugin_la-video.o
   .libs/libffmpeg_plugin_la-audio.o .libs/libffmpeg_plugin_la-video_filter.o
   .libs/libffmpeg_plugin_la-deinterlace.o .libs/libffmpeg_plugin_la-chroma.o
   .libs/libffmpeg_plugin_la-encoder.o .libs/libffmpeg_plugin_la-postprocess.o
   .libs/libffmpeg_plugin_la-demux.o .libs/libffmpeg_plugin_la-mux.o
   ../../../src/.libs/libvlc.dylib -L/usr/local/lib
   -L/Users/vajda/tmp/vlc/extras/contrib/lib /usr/lib/libiconv.dylib
   /usr/lib/libc.dylib -lpthread -lswscale -lavformat -lavcodec -lz
   /Users/vajda/tmp/vlc/extras/contrib/lib/liba52.a /usr/lib/libm.dylib
   /Users/vajda/tmp/vlc/extras/contrib/lib/libmp3lame.a -lavutil -lpostproc -lm
   -march=pentium-m -mtune=prescott -Wl,-read_only_relocs -Wl,suppress

   ld: absolute addressing (perhaps -mdynamic-no-pic) used in _rgb24tobgr24_MMX
   from /Users/vajda/tmp/vlc/./extras/contrib/lib/libswscale.a(rgb2rgb.o) not
   allowed in slidable image

Thanks !


More information about the vlc-devel mailing list