[vlc-devel] [RFC] Regarding the use of *_Control()
pdherbemont at free.fr
Tue Apr 15 07:09:14 CEST 2008
On Apr 14, 2008, at 6:57 PM, Jean-Paul Saman wrote:
> I think this is a useless change and shouldn't go in. Please use
> *_Control() as we do now.
May I ask you to re-consider?
Why do you think it's useless?
I do think it's much more readable:
- Characters count is less
- Prototype is declared in headers, today, there is no prototype, and
you have to look at the code to know what argument you should put in.
That's bad for autocompletion and such.
Remember, clean up the code is making it more maintainable, so don't
arg that it's useless.
I do wait your _objective_ arguments. Please don't tell about how much
work this is, as I plan to do the work.
Thanks for your answer,
More information about the vlc-devel