[vlc-devel] [RFC] Regarding the use of *_Control()
jpsaman at videolan.org
Tue Apr 15 08:57:55 CEST 2008
Pierre d'Herbemont wrote:
> On Apr 14, 2008, at 6:57 PM, Jean-Paul Saman wrote:
>> I think this is a useless change and shouldn't go in. Please use
>> *_Control() as we do now.
> May I ask you to re-consider?
> Why do you think it's useless?
> I do think it's much more readable:
> - Characters count is less
> - Prototype is declared in headers, today, there is no prototype, and
> you have to look at the code to know what argument you should put in.
> That's bad for autocompletion and such.
> Remember, clean up the code is making it more maintainable, so don't
> arg that it's useless.
> I do wait your _objective_ arguments. Please don't tell about how much
> work this is, as I plan to do the work.
Indeed my answer is somewhat subjective. What you propose is to break
module ABI. I got the impression that we as team didn't want that. Your
proposal only wraps the *_Contrlol() function without really rethinking
the module ABI.
If we are going down the road of redifining (and breaking the module
ABI), then I propose we do it proper by rethinking the way the
*_Control() functions are defined. The goal is then to end up with a
well-defined new module ABI (which is better maintainable and harder to
misues). IMHO that would be better, then just wrapping the old
*_Control() and thus adding a new layer of indirection.
More information about the vlc-devel