[vlc-devel] [RFC][PATCH] fix mozplug toolbar

Bill C. Riemers briemers at redhat.com
Wed Jun 18 17:04:59 CEST 2008

Jean-Paul Saman wrote:
>> Thanks, I tried that with 0.9.0, but same old problem:
>> checking for mozilla-config... no
>> checking for seamonkey-config... no
>> checking for xulrunner-config... no
>> configure: error: Please install the Mozilla development tools,
>> mozilla-config was not found.
> you miss the necessary development headers for firefox. You need the 
> following packages nspr-devel, firefox-devel to build. vlc-0.9.0 doesn't 
> need XPIDL= and XPIDL_INC= environment variables, these are only for 
> 0.8.6x versions.
> Gtz
> Jean-Paul Saman.
Where do I find firefox-devel and what should it contain? 

$ yum search firefox|grep '^firefox'
firefox.x86_64 : Mozilla Firefox Web browser
$ rpm -qa |egrep "firefox|nspr"
$ yumdownloader --source firefox > download.log 2>&1
$ sudo rpmbuild --rebuild firefox-3.0-1.fc9.src.rpm > build.log 2>&1
$ ls /usr/src/redhat/RPMS/*/firefox*

I have even tried downloading, building,  and installing the firefox
source from mozilla just in case the rpm package is missing something,
but still no joy.


More information about the vlc-devel mailing list