[vlc-devel] Problems with Mac OS X compile

Pavlov Konstantin thresh at altlinux.ru
Fri Jun 20 22:46:51 CEST 2008

On Fri, Jun 20, 2008 at 01:41:29PM -0700, Dave Still wrote:
> In which case, I get the following error from "./configure --enable- 
> debug --with-macosx-sdk":
> ...
> checking how to recognize dependent libraries... (cached) pass_all
> checking dlfcn.h usability... no
> checking dlfcn.h presence... yes
> configure: WARNING: dlfcn.h: present but cannot be compiled
> configure: WARNING: dlfcn.h:     check for missing prerequisite headers?
> configure: WARNING: dlfcn.h: see the Autoconf documentation
> configure: WARNING: dlfcn.h:     section "Present But Cannot Be  
> Compiled"
> configure: WARNING: dlfcn.h: proceeding with the preprocessor's result
> configure: WARNING: dlfcn.h: in the future, the compiler will take  
> precedence
> checking for dlfcn.h... yes
> checking how to run the C++ preprocessor... /lib/cpp
> configure: error: C++ preprocessor "/lib/cpp" fails sanity check
> See `config.log' for more details.
> As stated above, config.log reveals that /lib/cpp does not exist.   
> After examining the logs further, I tried to configure again, this  
> time with "CXXCPP='/usr/bin/cpp' ./configure --enable-debug --with- 
> macosx-sdk", which let things go a little further only to crash on a  
> libiconv error:
> ...
> checking for iconv... (cached) no, consider installing GNU libiconv
> configure: error: libiconv is needed for VLC to work properly
> I checked, and both /usr/lib/libiconv.dylib and /usr/include/iconv.h  
> exist.  I even tried adding "--with-libiconv-prefix=/usr" to the  
> configure options, but to no avail.  Is Apple's libiconv not  
> suitable?  I do not get these errors using just "./configure" with no  
> options.  Is there a problem with my development environment?  I have  
> pretty much a default XCode 3.1 installation.  I have Fink installed,  
> but not the development flags, so that should not be a conflict.  I'm  
> trying to build latest so that I can test the flash transcoding that I  
> was previously having issues with (see http://mailman.videolan.org/pipermail/vlc-devel/2008-April/042357.html 
>   ), and hopefully have them addressed before the upcoming test1  
> release.

Humm, that's the configure line I use for vlc on OSX:

./configure --enable-debug --disable-x11 --disable-xvideo --disable-glx
--enable-sdl --enable-mad --enable-libdvbpsi --enable-a52
--disable-dvdplay --enable-dvdnav --disable-dvdread --enable-ffmpeg
--enable-faad --enable-flac --enable-vorbis --enable-speex --enable-theora
--enable-ogg --enable-shout --enable-cddb --disable-cddax --enable-vcdx
--disable-skins --disable-skins2 --disable-wxwidgets --enable-freetype
--enable-fribidi --enable-caca --enable-live555 --enable-dca --enable-goom
--enable-modplug --enable-gnutls --enable-daap --enable-ncurses
--enable-libtwolame --disable-x264 --enable-png --enable-realrtsp
--enable-lua --disable-libtool --enable-csri --enable-asademux

Do you use contribs? I do. And i don't have Fink or Macports.

> >> 2. How can I (or someone) correct the error(s) that I'm getting?
> >
> > Fix ffmpeg pkg-config files.  They should report needed libraries in
> > Libs.private section.
> >
> This one is beyond me, I'm afraid.

I'll commit a fix for that in minutes.

My, how you've changed since I've changed.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20080621/95c48d27/attachment.sig>

More information about the vlc-devel mailing list