[vlc-devel] build error with ffmpeg

KH KH kwizart at gmail.com
Wed Jun 25 10:58:24 CEST 2008

2008/6/25 hce <webmail.hce at gmail.com>:
> On Tue, Jun 24, 2008 at 7:27 PM, KH KH <kwizart at gmail.com> wrote:
>> 2008/6/24 hce <webmail.hce at gmail.com>:
>>> Hi,
>>> I've just downloaded vlc 0.8.6h source tarball and compiled in FC7:
>>> ./configure --prefix=/home/work/Tools/VLC/Install
>>> --with-mad=/home/work/VLC/libmad-0.15.1b/Install
>>> --with-ffmpeg-tree=/home/work/Tools/VLC/ffmpeg/Install
>>> There was a configure: error: "Your FFmpeg library doesn't have the
>>> needed img_resample() function. You should rebuild it with software
>>> scaler disabled". I also svn ffmpeg and built the ffmpeg without
>>> "--enable-swscale software scaler support [default=no]". The software
>>> scaler was disabled, but why the vlc build still got that error? How
>>> can I fix it?
>> As it is told, you need to re-enable the deprecated img_resample
>> functions by using --disable-swscale in a recent ffmpeg snapshot.
> I tried ./configure --help in ffmpeg before I post here, it could not
> find ffmpeg supported -disable-swscale. But anyway it worked with
> -disable-swscale, that problem has been resolved.
> The next, it had following errors in make:
> /VLC/ffmpeg/libavformat/matroskadec.c:1023: undefined reference to
> `BZ2_bzDecompressInit'
> /VLC/ffmpeg/libavformat/matroskadec.c:1032: undefined reference to
> `BZ2_bzDecompress'
> /VLC/ffmpeg/libavformat/matroskadec.c:1035: undefined reference to
> `BZ2_bzDecompressEnd'
> What could be I missing?
Linking statically alsways produce weirdness, in this case you will
need to add --enable-ffmpeg-mastroska or else.
But if you take the ffmpeg*src.rpm, (from lvn8 which has swscale
disabled) you will have a shared version. And libraries dependencies
will be sorted more accurately.
>> On the other hand, Fedora 7 is also deprecated since one month after
>> Fedora 9 is out, so you can also consider to upgrade to a supported
>> Fedora version where vlc 0.8.6h is available.Longer support is made
>> available via CentOS (but no vlc pre-built package until rpmfusion.org
>> is up)
> Ok, I am going to install the latest version of CentOS 5.2, should
> that version of CentOS 5.2 be supported by VLC?
They is no "support" from the VideoLAN team from any other pre-build
package exept from their own, but if you ask if it will works, then
yes it should.
The best way to have vlc on CentOS is to rebuild src.rpm from livna 8
or 9 to CentOS, you can either build using mock (in chroot - which is
the best way), or use rpmbuild --rebuild any_package.src.rpm. But you
may probably need to tweak the spec file to fit your needs. (most of
them won't need to be tweaked)

Nicolas (kwizart)

More information about the vlc-devel mailing list