[vlc-devel] Problem when Streaming with VLC 0.9 over DCCP (in linux)

Ilkka Ollakka ilkka.ollakka+vlc at oamk.fi
Sat Mar 15 10:09:00 CET 2008

On la 15. maaliskuuta 2008 00:48:06, Bogdan Cornea wrote:
> Hello,
>   After your last reply, we used only the command line of vlc 0.9. We compiled the versions from 
>   13 and 14 march and here are the results:
> UDP & TCP streaming works;
> DCCP not working.

> In the case of DCCP we tried the following commands (and a lot of other parameter changes,but
>    still no streaming achieved): 
> ./vlc -I "dummy" "$@" file://~/Desktop/media/Fighter.mpg --sout '#duplicate{dst=rtp
>   {mux=ts,dst=localhost,proto=dccp}' --security-policy=1

 in here there's missing } in end (and no need for duplicate).
> ./vlc -I "dummy" "$@" file://~/Desktop/media/Fighter.mpg --sout "#rtp
>   {dst=localhost,ttl=10,mux=ps,proto=dccp,name=dccpServer}" --security-policy=1
  mux should be ts
> Can you please give us an example known to work with DCCP streaming? (We used the guide 
>   to "Advanced streaming using the command line" found in the /Streaming-howto section).

 I just tested quickly and in other vlc givin this:
 vlc -I dummy 001.ts --sout '#rtp{mux=ts,proco=dccp,dst=}'

 and another for receiving (on same machine since localhost is used)
 vlc dccp://localhost:50004

 and I get stream. that 50004 is not that clear, but streamer log tells
 that it's listening on that port.

Ilkka Ollakka
I'm rated PG-34!!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20080315/043cc113/attachment.sig>

More information about the vlc-devel mailing list