[vlc-devel] Problem when Streaming with VLC 0.9 over DCCP (in linux)

Bogdan Cornea bogdibvro at yahoo.fr
Sat Mar 15 00:48:06 CET 2008

  After your last reply, we used only the command line of vlc 0.9. We compiled the versions from 
  13 and 14 march and here are the results:
UDP & TCP streaming works;
DCCP not working.

http/tcp streaming command used:
./vlc -I "dummy" "$@" file://~/Desktop/Fighter.mpg --sout '#standard
  {access=http,mux=ogg,dst=localhost:8080}' --security-policy=1

udp streaming command used:
./vlc -I "dummy" "$@" file://~/Desktop/Fighter.mpg --sout '#std
  {access=udp,mux=ts,url=localhost:1234}' --security-policy=1

In the case of DCCP we tried the following commands (and a lot of other parameter changes,but
   still no streaming achieved): 
./vlc -I "dummy" "$@" file://~/Desktop/media/Fighter.mpg --sout '#duplicate{dst=rtp
  {mux=ts,dst=localhost,proto=dccp}' --security-policy=1
./vlc -I "dummy" "$@" file://~/Desktop/media/Fighter.mpg --sout "#rtp
  {dst=localhost,ttl=10,mux=ps,proto=dccp,name=dccpServer}" --security-policy=1

Can you please give us an example known to work with DCCP streaming? (We used the guide 
  to "Advanced streaming using the command line" found in the /Streaming-howto section).

Thanks for your prompt replies because they already helped a lot.


Rémi Denis-Courmont <rem at videolan.org> a écrit :
    Don't use the UI. 
  there are no ways to access DCCP through the UI, save from 
specifying parameters by hand - you're better using the command line at this 

 Envoyé avec Yahoo! Mail.
La boite email la plus appreciée au monde. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20080315/c373398f/attachment.html>

More information about the vlc-devel mailing list