[vlc-devel] [RFC] Shared objects naming

Jean-Paul Saman jpsaman at videolan.org
Fri May 16 11:55:39 CEST 2008

Rémi Denis-Courmont wrote:
> 	Hello,
> vlc currently spawns two shared objects: the core, providing the not-so-stable 
> plugin API, and the bindings API. 
> It is now obvious, as Zorglub(IIRC) had predicted, that the current names 
> confuse external developpers. It sounds like "libvlc" should be the external 
> binding API rather than the internal/plugin API, as it currently is. It is 
> probably our last chance to re-arrange this before it gets really too late.
> Hence I would propose that we change the names. Something like:
> libvlc v1 -> libvlccore v0
> libvlc-control v1 -> libvlc v2
> Opinions?

Jean-Paul Saman

More information about the vlc-devel mailing list