[vlc-devel] [RFC] Shared objects naming
Felix Paul Kühne
fkuehne.videolan at googlemail.com
Fri May 16 16:17:51 CEST 2008
-----BEGIN PGP SIGNED MESSAGE-----
On 15.05.2008, at 16:55, Rémi Denis-Courmont wrote:
> vlc currently spawns two shared objects: the core, providing the not-
> plugin API, and the bindings API.
> It is now obvious, as Zorglub(IIRC) had predicted, that the current
> confuse external developpers. It sounds like "libvlc" should be the
> binding API rather than the internal/plugin API, as it currently is.
> It is
> probably our last chance to re-arrange this before it gets really
> too late.
> Hence I would propose that we change the names. Something like:
> libvlc v1 -> libvlccore v0
> libvlc-control v1 -> libvlc v2
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (Darwin)
-----END PGP SIGNATURE-----
More information about the vlc-devel