[vlc-devel] dpkg-buildpackage using vlc-nightlies fails on hardy x86

Rafaël Carré funman at videolan.org
Sat May 24 19:34:04 CEST 2008

Le Sat, 24 May 2008 19:27:38 +0200,
Christoph Welcz <christoph at welcz.de> a écrit :

> Hello everyone!
> I posted an issue about a debian package of vlc-0.9x on videolan
> forums. The answer suggested to ask on this mailing list!
> http://forum.videolan.org/viewtopic.php?f=13&t=46717
> In order to get a version of vlc-0.9x with enabled ASA/CSRI support
> (which is as I believe disabled by default), I've tried to build my
> own debian package of vlc-nightlies. To make sure everything is fine
> I did not change anything in debian/rules and went for a initial test
> build.
> First I downloaded and extracted
> http://nightlies.videolan.org/build/hardy-i386/arch/vlc_0.9.0-git20080515-1.tar.gz.  
> To resolve all dependencies I entered the vlc-nightlies repository
> into my /etc/apt/sources.list:
> deb http://nightlies.videolan.org/build/hardy-i386/arch ./
> I installed vlc via apt-get install vlc and got the dependencies by
> apt-get build-dep vlc. dpkg-buildpackage reported some additional
> dependencies I had to install what I did with apt-get install
> <dependencies>.
> Finally I entered the build directory of vlc and tried for 
> fakeroot dpkg-buildpackage
> Unfortunately, this failed giving me the following error message:
> # Check that we did not install a plugin linked with libX11 in vlc-nox
> BORKED=no; \
>    for file in $(find debian/vlc-nox/usr/lib/vlc -name '*.so'); do \
>      if ldd $file | grep -q libX11; then \
>        BORKED=yes; \
>        echo $file depends on libX11; \
>      fi; \
>    done; \
>    if test "$BORKED" = yes; then exit 1; fi
> debian/vlc-nox/usr/lib/vlc/codec/libffmpeg_plugin.so depends on libX11
> make: *** [install] Fehler 1
> I'm not sure if it would make sense to upload my complete build log
> (approx. 2 MB?)
> I've already tried to get the vlc debian build from the debian svn as
> described in INSTALL, but it doesn't seem to work on ubuntu. I've also
> tried unsuccessfully to find some information in the web about this
> error message.
> any suggestions on further steps would be appreciated!

Try to run "./vlc-config --libs ffmpeg" from at the place where vlc is
built, to see if ffmpeg really links against libX11, then have a look
at config.log in the same build directory, to see why/when/where the
wrong dependancy was added.

Rafaël Carré
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20080524/7a03de67/attachment.sig>

More information about the vlc-devel mailing list