[vlc-devel] commit: Workaround warning on function returned value casted. ( Laurent Aimar )

Laurent Aimar fenrir at via.ecp.fr
Tue Aug 25 00:13:54 CEST 2009


On Tue, Aug 25, 2009, Pierre d'Herbemont wrote:
> On Aug 24, 2009, at 11:32 PM, Laurent Aimar wrote:
>> Yes, but I really hate when one part of the if use {} and the other  
>> one don't.
> Hum. I would remove it as it is taking more space than needed. No need  
> to fill with no op char.
> Whatever, no one seems to agree on the coding style.
> I would like a precise coding style such as WebKit's one, so that we  
> don't have to argue on taste.
> http://webkit.org/coding/coding-style.html

 If I had to to choose, I will choose K&R like ffmpeg does, but we have
already been there, so it's seems pointless to discuss it anymore.

 I will only enforce constant code style on the files I maintain or the
patch I apply


More information about the vlc-devel mailing list