[vlc-devel] commit: Workaround warning on function returned value casted. ( Laurent Aimar )

Rémi Denis-Courmont remi at remlab.net
Tue Aug 25 08:36:54 CEST 2009

On Tue, 25 Aug 2009 00:00:26 +0200, Pierre d'Herbemont
<pdherbemont at gmail.com> wrote:
>> Yes, but I really hate when one part of the if use {} and the other
>> one don't.
> Hum. I would remove it as it is taking more space than needed. No need
> to fill with no op char.
> Whatever, no one seems to agree on the coding style.
> I would like a precise coding style such as WebKit's one, so that we
> don't have to argue on taste.
> http://webkit.org/coding/coding-style.html

And then what? Run the whole code through indent, which will:
 - screw up in a few corner cases,
 - prevent back-porting fixes.

I suspect the cure is worse than the disease here.

Rémi Denis-Courmont

More information about the vlc-devel mailing list