[vlc-devel] [PATCH] GSoC: lua services discovery, first try

Pierre d'Herbemont pdherbemont at free.fr
Fri Jul 24 03:29:27 CEST 2009


Hey,

I fail to see the purpose of the patch. So I think the change log
description is not enough.

Plus random things:
+int services_discovery_AddParameterValue( services_discovery_t *p_sd,
+                                          const char *psz_parameter,
+                                          const char *psz_name,
+                                          const char *psz_format, ... )

This function name is not good because too generic. It needs to
describe its arguments more.

Also I  fail to see how this is related to service discovery. Either
it is too generic, or it simply belong to an other entity. What is
this function bringing?

+            if( !( event.u.services_discovery_item_put.psz_string =
+                                                       strdup( qtu(
string ) ) ) )
+                return;
+            vlc_event_send( &p_sd->event_manager, &event );
+            free( event.u.services_discovery_item_put.psz_string );

No need to strdup here.

+services_discovery_t * playlist_ServiceDiscoveryGetById( playlist_t
*p_playlist,
+                                                       int i_id )

Don't use id, use pointer directly. We want to deprecate those.

+    bool b_can_put;         /**< Set true if the sd has the ItemPut function */
+    bool b_can_get;         /**< Set true if the sd has the ItemGet function */
+    bool b_can_delete;   /**< Set true if the sd has the ItemDelete function */

What are those ItemPut/ItemGet/ItemDelete function? What are they
supposed to do?

Pierre.

On Tue, Jul 21, 2009 at 4:19 PM, Fabio Ritrovato<exsephiroth87 at gmail.com> wrote:
> Hi everyone,
> here's the first batch of patches for my SoC, hoping they are ok...
> The first one add new the ability to add, get and remove items from
> sds, and create a structure to hold the parameters and sd can
> accept...
> It also create uncachable modules (it will be needed in patch 3)
> Patch 2 is a qt4 dialog to pass data to a sd, but it's not the best in
> design terms... j-b offered to pimp it up, if the offer is still up...
> Patch 3 it's the actual work on lua sd, it's the backend part and 2 scripts...
>
> I noticed there's a typo in the patch name, I'll probably end up
> resubmitting them anyway, so I'll leave it for now :P
>
> Let me know if there's anything wrong...
>
> Best regards,
> Fabio Ritrovato
>
> _______________________________________________
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
> http://mailman.videolan.org/listinfo/vlc-devel
>
>



More information about the vlc-devel mailing list