[vlc-devel] commit: Added picture_pool_NewExtended. (Laurent Aimar )
pdherbemont at gmail.com
Tue Sep 8 02:26:04 CEST 2009
On Sep 7, 2009, at 11:05 PM, "Rémi Denis-Courmont" <remi at remlab.net>
> Le lundi 7 septembre 2009 23:57:52 Pierre d'Herbemont, vous avez écr
> it :
>> In this case NewWithConfiguration seems more appropriate. And
>> "configuration" should probably be "callback".
> Do you really need to invent the longest possible names all the time?
You are just saying, that short is good. And I do agree.
However someone new to the code will appreciate meaningful and clear
name. I am always open to better suggestion.
Also, if you want to put it that way, Extended is a waste of 8 chars.
I am concerned about this "lazy" way to extend existing API. And it
shouldn't be considered as a good practice, even if it's a common one.
Will you end up with an ExtendedExtended if you want a more
Generally the extended and non extend should be merged, or just renamed.
> And by the way, it has a performance impact. The linker does string
> at load time.
Huh?!. I think there are more important things to optimize... This
would be a one shot microoptimization, so, I would be curious to see
some numbers here.
However, if you think that matters we could write a tool to rewrite
our symbols, and use #define instead of the name! You didn't do it, so
I guess that you were kidding :P
More information about the vlc-devel