[vlc-devel] commit: Added picture_pool_NewExtended. (Laurent Aimar )
remi at remlab.net
Tue Sep 8 08:29:34 CEST 2009
On Tue, 8 Sep 2009 02:26:04 +0200, Pierre d'Herbemont
<pdherbemont at gmail.com> wrote:
> On Sep 7, 2009, at 11:05 PM, "Rémi Denis-Courmont" <remi at remlab.net>
>> Le lundi 7 septembre 2009 23:57:52 Pierre d'Herbemont, vous avez écr
>> it :
>>> In this case NewWithConfiguration seems more appropriate. And
>>> "configuration" should probably be "callback".
>> Do you really need to invent the longest possible names all the time?
> You are just saying, that short is good. And I do agree.
> However someone new to the code will appreciate meaningful and clear
> name. I am always open to better suggestion.
WithConfiguration reads just as stupid as Extended. In either case, it
won't scale to further adding parameters.
> Also, if you want to put it that way, Extended is a waste of 8 chars.
Yes. We might as well have a single function and give a NULL parameter to
get the non-extended behavior.
> I am concerned about this "lazy" way to extend existing API. And it
> shouldn't be considered as a good practice, even if it's a common one.
> Will you end up with an ExtendedExtended if you want a more
> specialized call?
And WithConfigurationAndSettings is supposed to be better?
More information about the vlc-devel