[vlc-devel] build vlc from git error

Feurstein, Michael Michael.Feurstein at wu.ac.at
Wed Aug 3 14:31:44 CEST 2011


ok for whatever reason it now works...

I configured it again with MacOSX10.5.sdk built it and it failed; then I tried again with MacOSX10.6.sdk and it worked.

I don't understand it but it works :)

Michael Feurstein

On Aug 3, 2011, at 11:59 AM, Feurstein, Michael wrote:


I've been successfully building http://sourceforge.net/projects/vlc/files/1.1.11/vlc-1.1.11.tar.bz2/download for some development purposes. Now in reference to my mail regarding qtcapture and audio I'm trying to build vlc from git in order to correctly do a git diff and then keep working with the git version.

However I can't seem to build the recent git://git.videolan.org/vlc.git

I'm following the instructions from OSXCompile Wiki with some extra parameters which all work with the vlc-1.1.11.tar.bz2 source but not with vlc.git source
Before building I did a git pull --rebase.

My set of commands:

export CC=/Developer/usr/bin/llvm-gcc-4.2
export CXX=/Developer/usr/bin/llvm-g++-4.2
export OBJC=/Developer/usr/bin/llvm-gcc-4.2

cd vlc/extras/contrib

cd ../..
./configure --build=i386-apple-darwin10 CFLAGS="-arch i386" CXXFLAGS="-arch i386" LDFLAGS="-arch i386" OBJCFLAGS="-arch i386" --with-faad-tree="/Users/michaelfeurstein/Development/VLC-libraries/faad2-2.7" --enable-faad --enable-debug --with-macosx-sdk=/Developer/SDKs/MacOSX10.6.sdk

I'm specifically using 10.6 SDK because somehow the QTCaptureDecompressedAudioOutput is missing in /Developer/SDKs/MacOSX10.5.sdk/System/Library/Frameworks/QTKit.framework/Headers

The make error:

   wizard.h \
   wizard.m \
   bookmarks.h \
   bookmarks.m \
   coredialogs.h \
   coredialogs.m \
   embeddedwindow.h \
   embeddedwindow.m \
   fspanel.h \
   fspanel.m \
   vout.m; do \
 cp "./modules/gui/macosx/$i" \
             ./tmp/modules/gui/macosx; \
  GEN    VLC.app
/usr/bin/install -c -d ./VLC.app/Contents/MacOS
touch ./VLC.app/Contents/MacOS/VLC
chmod +x ./VLC.app/Contents/MacOS/VLC
/usr/bin/install -c ./bin/.libs/vlc ./VLC.app/Contents/MacOS/VLC
install: ./bin/.libs/vlc: No such file or directory
make[2]: *** [VLC.app] Error 71
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

I checked the ./bin/.libs/ dir in vlc and only found vlc-cache-gen. However in ./bin/ dir  I have a vlc file. Is there something wrong with any links.
I'm out of ideas? Does this have to do with the GEN VLC.app? Could I build without GUI, but then again how do I develop for the GUI... Any hints would be greatly appreciated! I also posted this on the forums but without any luck...

I'd like to get this to work cause I am eager to get a replacement for video/audio streaming with Quicktime Broadcaster.

Thanks alot!

Michael Feurstein

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20110803/24d61ee6/attachment.html>

More information about the vlc-devel mailing list