[vlc-devel] Compiling VLC after extracting the contribs

Vandhanaa Lakshminarayanan vandhanaa91 at gmail.com
Thu Jul 14 12:15:03 CEST 2011


I am trying to compile vlc on mac os. It works fine as long as i use the
binaries of the contribs.
But I want to debug the "live" libraries. So what i did was
     1) ./bootstrap
     2) make src

i disabled a few libraries as i was getting quite many errors in them. I
tried to keep whatever was
essential alone.

after this when i start compiling vlc (bootstrap) i am getting this error:

++ dirname ./bootstrap
+ cd .
+ test -d extras/contrib/build/bin
++ uname -s
+ test .Darwin = .Darwin
+ set +x

ERR: Contribs haven't been built
ERR: Please run:
ERR:    'cd extras/contrib && ./bootstrap && make && cd ../..'
ERR: Make sure fink has been disabled too.

+ exit 1

Am i doing something wrong in this? the "make src" step was successful. I
want to debug the vlc along
with the libraries.

also i tried doing the same in Ubuntu. I successfully extracted the
libraries and i was also able to
compile vlc successfully. but when i tried to receive a stream the player
crashed with segmentation fault.
What am i doing wrong?

Thanks in advance!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20110714/a224b083/attachment.html>

More information about the vlc-devel mailing list