[vlc-devel] Getting stuck in stream_Read()

Casian Andrei skeletk13 at gmail.com
Wed Apr 4 17:05:16 CEST 2012

2012/4/4 Frederic YHUEL <fyhuel at viotech.net>:
> On Fri, Mar 30, 2012 at 11:59 AM, Frederic YHUEL <fyhuel at viotech.net> wrote:
>> 2012/3/30 Rémi Denis-Courmont <remi at remlab.net>:
>> > On Fri, 30 Mar 2012 11:29:15 +0200, Frederic YHUEL <fyhuel at viotech.net>
>> > wrote:
>> >> Actually it gets stuck in net_Read(), and more precisely inside the
>> >> call to poll().
>> >>
>> >> Since net_Read() calls poll() with no timeout, I'm not sure it is a
>> >> bug. But I have a really poor understanding of that stuff.
>> >>
>> >> Is it possible to blame the server? In that case, would it be possible
>> >> to have a timeout mechanism, like a net_Read flavour which calls
>> >> poll() with a timeout? (and the associated stream_Read variant?)
>> >
>> > Getting stuck in net_Read() is fine if the server is not sending any
>> > data.
>> > That is not a case for a timeout, unless the application layer protocol
>> > specifies timeouts.
>> >
>> > Of course, you are not supposed to get stuck to the point that the stop
>> > button does not act timely.
>> > But that is a case for some for of interruption/exception mechanism, not
>> > for ****ing^W^H polling timers.
>> >
>> Ok, thank you very much Rémi.
> Very strangely, I don't have this problem on my personal machine which
> runs Debian wheezy 64 bits. At work I have Ubuntu Oneiric 32 bits. I
> installed the 64 bits kernel of wheezy
> (linux-image-3.2.0-2-amd64_3.2.12-1_i386.deb) on this machine, and the
> problem is not there anymore.
> Is it possible that (32 bits) Ubuntu kernel have a buggy poll() ? I
> guess that launchpad would have been flooded by bug reports in that
> case, so I don't understand... any idea?
I am witnessing this kind of behavior when using the internet
connection from my campus. It's affecting only certain addresses and
it seems it's ISP related. I have to mention that everything that uses
http is affected.

While debugging VLC when it tried to contact certain problematic
addresses, it got stuck in net_Read(), just like you describe.

So, I am suggesting that this might be an ISP issue. Any network
debugging I tried was futile, maybe you will have more luck.

> Best Regards,
> --
> Frédéric
> _______________________________________________
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
> http://mailman.videolan.org/listinfo/vlc-devel

More information about the vlc-devel mailing list