[vlc-devel] Alsa buffer duration. Invalid argument.

Peter Tap ptrtap at yahoo.com
Thu Oct 25 19:07:58 CEST 2012


I did a comparison for alsa.c between 2.0.3 and 2.0.4. They were identical. I also did a comparison between my ./configure flags and the ones that were used to build the packaged version of 2.0.3. They are identical. 

I also searched the Internet. There was a similar problem in alsa.c for which a patch was submitted. Here is the link: http://mailman.videolan.org/pipermail/vlc-commits/2012-March/013374.html. However, I didn't find this patch code either in 2.0.3 version or in 2.0.4 version of alsa.c.

I commented out the call to "snd_pcm_hw_params_set_buffer_time_near" in alsa.c. That fixed my problem. But there must be a better solution.

Any help would be appreciated in understanding where else to look for a possible code difference.


----- Original Message -----
From: Rémi Denis-Courmont <remi at remlab.net>
To: Mailing list for VLC media player developers <vlc-devel at videolan.org>
Sent: Thursday, October 25, 2012 3:52 AM
Subject: Re: [vlc-devel] Alsa buffer duration. Invalid argument.

On Wed, 24 Oct 2012 17:00:09 -0700 (PDT), Peter Tap <ptrtap at yahoo.com>
> When I run packaged version of vlc, all my speakers work as expected.
> When I run my custom version of vlc,  I do not get any sound.

You know, you have all the data, and nobody else here does. In particular,
you have the source code and history for both versions and you have the
hardware that exhibits the problem. That should be all you need to figure
out what the differences comes from. Nobody else can.

Rémi Denis-Courmont
Sent from my collocated server
vlc-devel mailing list
To unsubscribe or modify your subscription options:

More information about the vlc-devel mailing list