[vlc-devel] [PATCH] Input and Output modules for the Reliable Internet Stream Transport (RIST) Protocol.

Sergio M. Ammirata sergio.ammirata at sipradius.com
Wed Oct 24 09:26:59 CEST 2018


Hello Alexandre,

 

I was not aware of vlc_cleanup_push(free, ptr). I will make the changes and eliminate the overuse of block_t.

 

I will also make the suggested change and append _i11e to the read and write functions to make it easier to identify cancellation points when reading the code.

 

Regards,

 

Sergio Ammirata

 

From: vlc-devel [mailto:vlc-devel-bounces at videolan.org] On Behalf Of Alexandre Janniaux
Sent: Monday, October 22, 2018 11:05 AM
To: Mailing list for VLC media player developers
Subject: Re: [vlc-devel] [PATCH] Input and Output modules for the Reliable Internet Stream Transport (RIST) Protocol.

 

Hi,

 

Do you really need to use block_t for simple memory allocation ? For example in `send_rtcp_feedback`, it seems to me that malloc will do fine.

 

If you do need to guard against cancellation, you can use `vlc_cleanup_push(free, ptr);` instead.

 

I also find it a little bit confusing to understand what is a cancellation point and what is not, maybe you could add a comment close to where you use `rist_WriteTo`, or rename it to `rist_WriteTo_i11e` ?

 

Otherwise, +1 for str*cpy.

 

Best regards,

-- 

Alexandre Janniaux

 

Le lun. 22 oct. 2018 à 09:39, Thomas Guillem <thomas at gllm.fr> a écrit :



On Mon, Oct 22, 2018, at 09:23, Thomas Guillem wrote:
> 
> On Mon, Oct 22, 2018, at 02:42, Jean-Baptiste Kempf wrote:
> > 
> > On Sun, 21 Oct 2018, at 16:57, Sergio M. Ammirata wrote:
> > > All issues are fixed, here is in the revised input module patch.
> > 
> > So:
> > - missing NEWS, po/POTFILES.in, modules/MODULE_LIST entries
> > - you must surround the poll.h include with HAVE_POLL
> 
> > - use str*cpy instead of strcpy
> 
> Where strcpy is used, dst and src have the same length. I don't know the 
> convention, but for me, strcpy is good in that case.

Forget it, I though the src param was static const, but it's not. So yes, strcpy is bad here.

> 
> > 
> > Also, you have many options in this module. Are they all necessary?
> > 
> > best,
> > 
> > 
> > -- 
> > Jean-Baptiste Kempf -  President
> > +33 672 704 734
> > _______________________________________________
> > vlc-devel mailing list
> > To unsubscribe or modify your subscription options:
> > https://mailman.videolan.org/listinfo/vlc-devel
> _______________________________________________
> vlc-devel mailing list
> To unsubscribe or modify your subscription options:
> https://mailman.videolan.org/listinfo/vlc-devel
_______________________________________________
vlc-devel mailing list
To unsubscribe or modify your subscription options:
https://mailman.videolan.org/listinfo/vlc-devel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc-devel/attachments/20181024/93aa38d4/attachment-0001.html>


More information about the vlc-devel mailing list