[vlc-devel] [PATCH 12/18] libvlc: rename libvlc_video_direct3d_device_cfg_t / libvlc_video_setup_device_info_t

Steve Lhomme robux4 at ycbcr.xyz
Wed Feb 5 13:07:05 CET 2020

On 2020-02-04 19:57, Rémi Denis-Courmont wrote:
> Le tiistaina 4. helmikuuta 2020, 17.26.07 EET Steve Lhomme a écrit :
>> To more generic names.
>> No functional changes.
> Seems more logical to have this before the previous patch.


> Also the compound type should probably be a union if it's to support
> completely different APIs.

I thought using union in the libvlc API was not a good idea (all 
languages that can use libvlc support that ?), but it seems we already 
use it in places. So it's doable.

More information about the vlc-devel mailing list