[vlc] Problems (Sound, Transcoding, Codecs, Logs) On Ubuntu Intrepid (8.10)

Hal Vaughan hal at thresholddigital.com
Thu Jan 8 18:25:20 CET 2009

Thanks for responding!

On Thursday 08 January 2009, you wrote:
> Le jeudi 1 janvier 2009 19:32:03 Hal Vaughan, vous avez écrit :
> > 1) No logging.  I tried to set the log to ~/tmp/vlc-log.txt and
> > nothing is logged to that file.  As a matter of fact, even when I
> > forced errors by loading a bad file, this log file wasn't even
> > created.  I finally looked in my home directory and found
> > ~/.vlc/vlcrc and in that config file all the log settings were
> > commented out, so I uncommented them to set up a log file, with no
> > success.  I get the error messages from VLC, but there is no log to
> > check for more details.
> The configuration is in .config/vlc as per the FreeDesktop
> specifications.
> > 3) When I play the .mts files, I have to select, each time, to
> > discard interlacing.  Can't I set this somewhere?  There doesn't
> > seem to be a place in the preferences where I can do this.
> Duh? We have deinterlacing (disabled by default), but we have no such
> thing as interlacing.

When I play any .mts file, I see an effect that's the same as when I 
used to play files imported from a miniDV camcorder without specifing 
deinterlacing.  I would assume that VLC is automatically deinterlacing 
the video, even though it doesn't need it.  When I specify to discard 
deinterlacing, I get a clear picture.  I'm trying to make it do this 
automatically without me having to specify it.

> > 4) I've tried saving my preferences, but sometimes that locks the
> > program.  It'll keep playing a video, but the UI doesn't respond
> > and I have to kill it and restart it.
> Stacktrace? I cannot reproduce the problem.

How do I get a stacktrace on a frozen program in KDE?  I can run it from 
the command line.  I tried that and, of course, the problem doesn't show 
up!  (I'll report if this comes back.)

> > 5) I've tried transcoding my .mts files to a format more programs
> > understand, but I can't transcode to MP4.  I get errors that the
> > codec or encoder is not there.  I've installed all the packages
> > that should be connected with VLC and codes, but I still get
> > reports that the MP4 video and AAC audio codec or encoders are not
> > there (I figure this might be part of the sound issues as well). 
> > The error messages tell me to check the log for more details, but
> > there's no log file.
> *Ubuntu* decided to remove all MPEG encoders. The VideoLAN project
> was not involved in this decision, and there is nothing it can do
> about it.

Okay, so did they remove them from just VLC, or overall?  Is there a 
package I can install to restore them?



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/vlc/attachments/20090108/51adf23c/attachment.html>

More information about the vlc mailing list