[vlc] Encoded/Saved Files Never Have Video

Jean-Paul Saman jpsaman at videolan.org
Tue Jan 20 10:08:04 CET 2009

Hal Vaughan wrote:
> Thank you for a reply!  Much appreciated!
> On Monday 19 January 2009, you wrote:
>> Hal Vaughan wrote:
>>> On Wednesday 14 January 2009, Hal Vaughan wrote:
>>>> This problem first showed up with .mts files, but I'm having the
>>>> same problem with .mp4 files now.  I'm on Ubuntu Intrepid Linux
>>>> and I have downloaded all the codecs.  Whenever I try to transcode
>>>> a file in VLC, I end up with an output file with audio and no
>>>> video.  I've fiddled with settings and tried different input
>>>> files, but I never get video output.
>>>> What do I need to do to make this work?
>> 1) do not use debian or ubuntu because they come with crippled codec
>> libraries.
>> OR
>> 2) deinstall ffmpeg and compile it yourself from ffmpeg source code
> If the codec is not there, how can I view the video in a file but not 
> get video when it transcodes it -- even to open codecs like Ogg?

It means that you do not have the encoder libraries installed for those 
formats. I am not an Ubuntu user so cannot tell you exactly how the 
libraries are named. For OggVorbis you need the vorbis encoder library 

FFmpeg could be compiled in such a way that it doesn't include the 
encoder version of the codecs, but only the decoding version. Hence you 
can view the movies, but not encode in them.

> I've been told, specifically, and on this list, that "You can install 
> libavcodec52-unstripped (and friends) or use the
> libavcodec of medibuntu"  which I've done.  While Ubuntu and Debian may 
> have fewer codecs in the main distro, for as long as I've been using 
> Debian (over 5 years now) and, as best I could see on Ubuntu, from the 
> start, they've had separate repositories of the non-free software such 
> as codecs.
> Are you saying that even with the non-free repositories for Ubuntu, the 
> codecs still aren't there?  Again, if the codecs aren't there, how can I 
> still see the video, both the original .mts file and the .mp4 file 
> HandBrake produces, played back to me?

Again I am not an ubuntu user myself, but the last year we got many 
reports on functionality ceasing to work. Almost all of them where 
traced back to missing codecs in ffmpeg. Hence my answer to you.

> I'm not trying to argue, but I've gotten different answers from 
> different people, so I'm really quite confused.  About 6 months ago, on 
> an earlier version of Ubuntu, I had transcoding working perfectly with 
> this bash script:
> #!/bin/bash
> vcodec="mp4v" 
> acodec="mp4a" 
> bitrate="4096" 
> arate="512" 
> ext="mpg" 
> mux="mp4" 
> vlc="vlc" 
> fmt="dv" 
> $vlc -I dummy -vvv $1 --sout 
> "#transcode{vcodec=$vcodec,vb=$bitrate,acodec=$acodec,ab=$arate,channels=2}
> :standard{mux=$mux,dst=$2,access=file}" vlc:quit
> (The last was all one line, split here for email.)  The only problem I 
> had with it was that when it was done, VLC would not quit, I had to kill 
> it with CTRL-C.  (Any help on why the vlc:quit doesn't work as in the 
> man page would be appreciated as well!)

Ubuntu seems to have changed their policies regarding what codecs they 
can *legally* support.

>>> Previously someone told me what video codecs I needed to install to
>>> make this work.  I've installed them.
>>> Is this not the right place to get help with this?
>> Yes it is, but you need to give us more information:
>> - what VLC version are you using?
>> - send us the logging output of vlc
>> - send the commandline used.
> I did that once before, after they were asked, and nobody responded to 
> that post.  I'm using VLC 4.3.2.  I've had problems with the command 

version 4.3.2 ?? that version doesn't even exist. The current stable is 
numbered 0.9.8. I suppose you mean another version of vlc. You can check 
this in the about box in the gui or with vlc --version from the commandline.

I am terribly sorry that nobody picked up on your return e-mails. You 
have to understand we are a rather small team of volunteers with limited 
time. The best advise I can give you is to repost your question after a 
week if you got no response. That will hopefully bring your question 
back to peoples attention.

> line.  I can pick "Convert/Save" and set it up, it gives me a command 
> line, but when I cut and paste that line into the console after the 
> command "vlc" it doesn't work.  To get this output, I ran VLC from the 
> console as just "vlc", then when I used "Convert/Save" and set that up, 
> (using MP4 as the container, video, and audio codecs) this was the 
> resulting command line it said to use:
> :sout=#transcode{vcodec=mp4v,vb=800,scale=1,acodec=mp4a,ab=128,channels=2}:duplicate{dst=std{access=file,mux=mp4,dst=/data/Data/Video/Dance/Performances/SweptAway-
> DeepRun-VLC.mp4}}
> I clicked on "Save" and it did the conversion.  Here's the command line 
> output, from command to run VLC:
> [hal at wizard:RawMTS]$ vlc
> VLC media player 0.9.4 Grishenko
> [00000001] main libvlc debug: VLC media player - version 0.9.4 Grishenko 
> - (c) 1996-2008 the VideoLAN team
> [00000001] main libvlc debug: libvlc was configured with ./configure  
> '--build=x86_64-linux-gnu' '--enable-maintaner-mode' '--enable-release' 
> '--prefix=/usr' '--enable-libtool' '--enable-fast-install' '--with-
> binary-version=1ubuntu3' '--disable-update-check' '--disable-gnome' '--
> disable-gtk' '--disable-familiar' '--disable-fb' '--enable-ggi' '--
> enable-sdl' '--enable-esd' '--enable-mad' '--enable-arts' '--enable-
> jack' '--enable-pulse' '--enable-lirc' '--enable-a52' '--enable-aa' '--
> enable-dvbpsi' '--enable-mozilla' '--with-mozilla-pkg=libxul-plugin' '--
> disable-kde' '--enable-mp4' '--enable-dvb' '--disable-satellite' '--
> enable-ogg' '--enable-vorbis' '--enable-shout' '--enable-qt4' '--
> disable-slp' '--enable-flac' '--disable-skins' '--disable-basic-skins' 
> '--enable-skins2' '--enable-freetype' '--enable-mkv' '--enable-speex' 
> '--enable-caca' '--enable-live555' '--enable-libmpeg2' '--enable-
> fribidi' '--enable-cdio' '--enable-mod' '--enable-theora' '--enable-
> modplug' '--enable-dvdnav' '--enable-gnutls' '--enable-ffmpeg' '--
> enable-ncurses' '--enable-smb' '--disable-gnomevfs' '--enable-bonjour' 
> '--enable-mpc' '--enable-vcd' '--enable-vcdx' '--enable-notify' '--
> enable-twolame' '--enable-x264' '--enable-faad' '--disable-zvbi' '--
> enable-telx' '--enable-mediacontrol-bindings' '--disable-atmo' '--
> enable-taglib' '--enable-libass' '--enable-libdca' '--enable-alsa' '--
> enable-dv' '--enable-v4l' '--enable-v4l2' '--enable-pvr' '--enable-
> svgalib' '--enable-dvd' '--without-dvdcss' 'build_alias=x86_64-linux-
> gnu' 'CFLAGS=-g -O2' 'LDFLAGS=-Wl,--as-needed' 'CPPFLAGS=' 'CXXFLAGS=-g 
> -O2'
> [00000001] main libvlc debug: translation test: code is "C"
> [00000001] main libvlc: Running vlc with the default interface. Use 
> 'cvlc' to use vlc without interface.
> libdvbpsi error (PSI decoder): TS discontinuity (received 1, expected 0) 
> for PID 0
> libdvbpsi error (PSI decoder): TS discontinuity (received 1, expected 0) 
> for PID 256
> [00000477] a52 packetizer: A/52 channels:2 samplerate:48000 
> bitrate:256000
> [00000492] a52 decoder: A/52 channels:2 samplerate:48000 bitrate:256000
> In case there's an issue with codecs, I did it again, specifying Ogg as 
> the encapsulation, video and audio.  Here's the command:
> :sout=#transcode{vcodec=theo,vb=800,scale=1,acodec=vorb,ab=128,channels=2}:duplicate{dst=std{access=file,mux=ogg,dst=/data/Data/Video/Dance/Performances/SweptAway-
> DeepRun-Ogg.mp4}}
> And here's the output from just that command:
> [00000538] mux_ogg mux: Open
> libdvbpsi error (PSI decoder): TS discontinuity (received 1, expected 0) 
> for PID 0
> libdvbpsi error (PSI decoder): TS discontinuity (received 1, expected 0) 
> for PID 256
> [00000545] a52 packetizer: A/52 channels:2 samplerate:48000 
> bitrate:256000
> [00000546] a52 decoder: A/52 channels:2 samplerate:48000 bitrate:256000

Both snippits are too small to be able to say for sure what the problem is.

> Again, the output file has audio and no video.  This is from the same 
> .mts file that Handbrake had no problem converting to .mp4 with sound 
> and video.  Ideally, I'd like to use VLC, convert the .mts file to 2 
> different .mp4 files, one that's 16:9, for my use and YouTube uploads 
> (the .mts files don't always work right with YouTube) and also create a 
> letter-boxed 4:3 .mp4 to use to create DVDs for other people.  It'd be 
> nice to be able to produce both files with one program that I can set up 
> with a script to make it easy to batch convert.

This means that you do not have a mp4 encoder library installed on your 
system. In vlc ffmpeg handles this task. Thus the encoder versions are 
missing from ffmpeg.

The above brings me back to my recommendation above point 1) and/or 2).

> If it helps anyone, an .mts file I was working with is on my blog 
> website.  This is not the file I'm currently working with, but it's one 
> that YouTube accepted for upload in its original form and one that 
> Handbrake converted without problem and it has all the same issues in 
> VLC that the current file I'm using does.
> http://halblog.com/videocheck/00027.mts
> Thanks, again, for any help on this!

I hope this clarifies things for you.

Jean-Paul Saman.

More information about the vlc mailing list