[x265] [PATCH] changed the naming convention for blockcopy_sp

praveen at multicorewareinc.com praveen at multicorewareinc.com
Tue Nov 5 10:59:07 CET 2013


# HG changeset patch
# User Praveen Tiwari
# Date 1383645536 -19800
# Node ID b5bdc10daa02d7d769263c5adb63fe3026ea4ba0
# Parent  33486d409515d5f9fd451818f7623a92690a219d
changed the naming convention for blockcopy_sp

diff -r 33486d409515 -r b5bdc10daa02 source/common/x86/pixel.h
--- a/source/common/x86/pixel.h	Tue Nov 05 15:13:42 2013 +0530
+++ b/source/common/x86/pixel.h	Tue Nov 05 15:28:56 2013 +0530
@@ -272,7 +272,7 @@
 
 #define SETUP_CHROMA_BLOCKCOPY_FUNC(W, H, cpu) \
     void x265_blockcopy_pp_ ## W ## x ## H ## cpu(pixel *a, intptr_t stridea, pixel *b, intptr_t strideb);\
-    void x265_blockcopy_ps_ ## W ## x ## H ## cpu(pixel *a, intptr_t stridea, int16_t *b, intptr_t strideb);
+    void x265_blockcopy_sp_ ## W ## x ## H ## cpu(pixel *a, intptr_t stridea, int16_t *b, intptr_t strideb);
 
 #define CHROMA_BLOCKCOPY_DEF(cpu) \
     SETUP_CHROMA_BLOCKCOPY_FUNC(4, 4, cpu); \
@@ -302,7 +302,7 @@
 
 #define SETUP_LUMA_BLOCKCOPY_FUNC(W, H, cpu) \
     void x265_blockcopy_pp_ ## W ## x ## H ## cpu(pixel *a, intptr_t stridea, pixel *b, intptr_t strideb);\
-    void x265_blockcopy_ps_ ## W ## x ## H ## cpu(pixel *a, intptr_t stridea, int16_t *b, intptr_t strideb);
+    void x265_blockcopy_sp_ ## W ## x ## H ## cpu(pixel *a, intptr_t stridea, int16_t *b, intptr_t strideb);
 
 #define LUMA_BLOCKCOPY_DEF(cpu) \
     SETUP_LUMA_BLOCKCOPY_FUNC(4,   4, cpu); \


More information about the x265-devel mailing list