debian/ scripts bug in CVS

Rens Houben shadur at
Tue Jun 5 12:22:04 CEST 2001

With the latest sid (unstable) updates, the package libglide-dev no longer
exists, having been explicitly split into libglide2-dev and libglide3-dev. 

This change breaks the Build-Depends check during dpkg-buildpackage. 

the following patch fixes this:

--- debian/control.old	Tue Jun  5 12:17:05 2001
+++ debian/control	Tue Jun  5 11:58:09 2001
@@ -2,7 +2,7 @@
 Section: graphics
 Priority: optional
 Maintainer: Samuel Hocevar <sam at>
-Build-Depends: debhelper (>=2.2.0), xlib6g-dev, libgnome-dev, libggi2-dev, libglide-dev [i386], libesd0-dev, libsdl1.2-dev, libqt-dev, libasound2-dev
+Build-Depends: debhelper (>=2.2.0), xlib6g-dev, libgnome-dev, libggi2-dev, libglide2-dev|libglide3-dev [i386], libesd0-dev, libsdl1.2-dev, libqt-dev, libasound2-dev
 Standards-Version: 3.0.1
 Package: vlc

I'll post some more once I get home and have a chance to check it out better.

Rens Houben
Resident linux guru and sysadmin
Systemec Internet Services.

More information about the vlc-devel mailing list