[vlc-devel] Re: VLC 0.6.0-test1

Anatoly R. emulynx at delfi.lv
Wed May 21 20:30:45 CEST 2003

Hello Gildas,

Wednesday, May 21, 2003, 2:38:19 AM, you wrote:

>> Time seeking problem for m2v files wasn't solved and I don't think
>> it's in your todo list. I'm playing musicvideos in m2v format and
>> playing time is always incorrect for thousands of files.

GB> Did you fill a bug report in bugzilla ? That helps us not to forget about 
GB> requests/bugs.

I was discussing this with couple of developers at #videolan couple of
monthes ago and they said nothing can be done since the original way
of processing frames. Don't remember what was the specific reason, but
I think it was lack of keyframes or something like that (the same
reason they refused to add next/previous frame support).

>> I saw that first step to keep window size after playlist entry change
>> (first movie ends, second one starts) was done in CVS but this release
>> doesn't feature any improvements of that kind.

GB> I guess we can add a configuration option for this (disabled by default).

I hope so.

>> I've got new box some time ago. It's Compaq Evo D510 ePC.
>> It has P4 2.4ghz processor and integrated Intel video/audio/network.
>> The box is very compact and small but VLC started to lock up for 4-5
>> seconds each ~40 seconds of playing. I'm going to try 0.4.x branch if
>> you want, but that happens to 0.5.0, 0.5.1 and latest 0.6.1. This
>> doesn't happen anywhere else.

GB> Hmmm, never seen this. Does it happen only when playing special files, or 
GB> maybe DVDs ? What happens if you disable the video (--novideo) or the audio 
GB> (--noaudio) ?

Ehm, everywhere sir.  I've tried to play everything without audio -
video was stopping at constant rate. When I tried it without video -
same problem, audio was stopping sometimes.

I've tried Animatrix DivX (xvid) and the same problem appeared. This
doesn't happen in any other applications. I'm using dozens a lot of
different apps and there are nothing like that.

This happens to all VLCs (i've tried 0.3.1, 0.4.0, 0.4.6, 0.5.x) so it
should be problem on my side.

Another problem appeared when watching DivX. Seeking using the bar is
completely wrong. I try 0:47:00 and I get 0:56:xx. I try 02:22 and I
get 02:18. I try 0:14:27 and I get 0:17:xx. Same thing happened with
other file (Friday After Next). I don't think that somebody would
encode movie with keyframes every 3 minutes (25*60*3, that was average
jump in FAN). It seeks absolutely fine in Media Player (ffdshow +

Another problem appeared after I was resizing window a lot - from
maximum to minimum and checking how the progress bar resizes with time
pointer. Time was ticking incorrectly. Sometimes it was like 0:35:37
then 0:35:38 then shortly 0:35:37 and right after that 0:35:39...
Some different problems like that exist, try it with different

Next thing - if the filename doesn't fit under "File" tab in "Open
Target" dialog (here's the example):


Default text align might be "to the RIGHT border" so we would see
actual filename
instead of

What's next? There's no "File Open" history. You know what to do :)

I brought some Audio CDs and I was able to hang player somehow for a
bit - I was in playlist and had "cdda://D:@1:1" selected, then I tried
to right click on seeker bar. It stopped! That's strange... Seeking
wasn't working, there was an Icon "Stop" so it wasn't stopped. I
pushed it, nothing happened. Pushed "Play" - it worked.

CD audio support is very strange. I've added one sound track but it
kept playing all of them. Audio Device (not sure) / Audio Channels
options do not work with CD audio, but there are context menus for

Minimal width of Playlist should be locked to width of "Url" +
"Duration" probably. Duration of CD track is not shown :(
Actually, duration is not shown for all types (yet) as far as I

I also can't understand "Title", "Navigation" and "Audio Track" in
popup menu. Title has 1-20 (as example) but Navigation has "Title 1"
to "Title 20" :)
Audio track has "Disable" and "Track 1" options. If I disable it,
track is still being played (cdrom is spinning and reading track) but
nothing is being heard. Where are other Tracks? May be "Track 1"
should be replaced by "Session"?

BTW, same thing happens to Audio CD (lock ups). Player stops for 1
second and then continues to play. CD stops too! (Tried WinAMP,
foobar2000, media player - works fine). And the most funny part that
the sound is played a bit slower (70%) than it should for couple of
seconds and then slides to 100%.

I've tried to add "cdda://D:@1:1" to playlist, then I added 2 movies.
I've selected last audio track in "Title" menu, seeked to the end and
waited till it ends. It crashed. XP said "nuff" ;)

vlc.exe has encountered a problem and needs to close.
We are sorry for the inconvenience.

AppName: vlc.exe         AppVer:         ModName: ntdll.dll
ModVer: 5.1.2600.1106    Offset: 0000214f

It also generated useless log of all modules in memory and small
memory dump which was shown on the screen but there was no way to
copy-paste or save or do anything with it (I hate XP, but that box is
XP optimised and it's too damn hard to install Win2k cause some of the
Intel drivers signed specifically for XP).

I've tried to do the same thing again - it crashed.

Time to go home. I hope that I'll have a chance to use VLC this summer
to play playlists loaded with musicvideos and after resizing and
switching to next video it's size will be the same as previous'.
That's all I really want ;)

http://foo.lynx.lv                          mailto:emulynx at delfi.lv

This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html
If you are in trouble, please contact <postmaster at videolan.org>

More information about the vlc-devel mailing list