[vlc-devel] Re: Cannot access MJPG streams

Iván Sánchez Ortega i.sanchez at mirame.net
Wed Jul 6 11:42:44 CEST 2005

El Martes, 5 de Julio de 2005 18:59, Rémi Denis-Courmont escribió:
> > access_http error: invalid HTTP reply '--myboundary'
> > main error: cannot pre fill buffer
> This stream works fine for me at the moment.
> Nevertheless, it seems that the HTTP server legocamera.marshall.edu
> sends LF as end of lines, instead of CRLF in HTTP headers. That's in
> violation of RFC2616, section 6, and may account for your problem.

The problem here is that every network camera manufacturer uses the MJPEG 
format he wants. That means things like "hey, let's get rid of this \r\n" and 
"hey, let's put an invalid Content-Lenght header just to screw things up".

> [...] I've tried to make the development version more robust as regards LF 
> vs CRLF but given I can't reproduce your problem, I don't know if it's going 
> to change anything.

I've just tried to reproduce the problem with VLC 0.8.2 on my Debian computer, 
and everything seems to work just fine (VLC just drops every "Content-Lenght" 
header from streams that implement it, plays the video perfectly). I wonder 
what the hell went wrong in the Windows compile... :-/

Iván Sánchez Ortega <i.sanchez at mirame.net> <ivansanchez at escomposlinux.org>

Una frase puede cambiar un destino.
		-- George Fischer. 

This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html

More information about the vlc-devel mailing list