[vlc-devel] Re: problem to load modules

Benjamin Pracht bigben+spam at videolan.org
Fri Jun 24 18:31:29 CEST 2005

On Fri, Jun 24, 2005, bertrand pelardy wrote :
> hi,
> I put vlc under java (with jni), then i tried to run
> vlc under OSGi, and now I got one error. It didn't
> find the modules. However there are "vlc.exe" in the
> cache of osgi and /modules. I would like more
> information about modules.c, it means that I read 
> that you used LoadLibrary under windows(I worked on
> win xp and vlc 0.8.1)
> I got this message error :
> [00000021] main interface error: option intf does not
> exist
> [00000021] main interface error: no interface module
> matched "any"
> [00000021] main interface error: no suitable intf
> module
> [00000001] main vlc error: interface "(null)"
> initialization failed

Well, that could be an environment issue : It might be that jni doesn't
give the VLC executable in which directory it was launched. Since VLC
will search the modules in a subdirectory of that one, there could be

Can you try to add the --plugins-path=<directory where the plugins are> option ?

That is no definitive solution, but will allow us to determine if this
is the issue...


This is the vlc-devel mailing-list, see http://www.videolan.org/vlc/
To unsubscribe, please read http://developers.videolan.org/lists.html

More information about the vlc-devel mailing list