[vlc-devel] [PATCH 4/4] contribs: bootstrap no longers force a -j$CPU because the dependancies are screwed up anyway.

Dominique Martinet asmadeus at codewreck.org
Mon Apr 18 11:46:14 CEST 2011

Dominique Martinet wrote on Mon, Apr 18, 2011 :
> I did a whole rebuild just now to check I wasn't imaginating things, bear
> in mind it's with a dev-oriented system and lots of dependancies already,
> so there might be other errors.. But even then gettext finds a
> dependancy with iconv, but .intl doesn't depend on .iconv

Okay, that is weird.. I just built only .intl out of a clean contrib and
it worked, and redid all in a row which worked too (with -j1)
The configure apparently decided to add a -DDEPENDS_ON_LIBICONV=1 to the
compilation option and accordingly added a -liconv which didn't work
later on due to a bad timing with the multibuilds, I could paste the
build log but I can't reproduce it (and no longer have the config.log

I did however a series of build (for all the targets, build just one and
clean up) on a freshly installed debian machine and it's all good with
-j1; there are a few bugs I'll submit a patch for later, but nothing
wrong with the dependancies apparently..
Now why doesn't it work just as well when building with -j4, I don't
know :p

So sorry for badmouthing, even if I think there's a problem somewhere I
can't pinpoint, and keep it up :)


Dominique Martinet | Asmadeus

More information about the vlc-devel mailing list