[x265] [PATCH] Encoder: Removed Code Duplication and made the common function for nal data extraction

Derek Buitenhuis derek.buitenhuis at gmail.com
Thu Sep 12 12:03:30 CEST 2013


On 9/12/2013 10:56 AM, Gopu Govindaswamy wrote:
> # HG changeset patch
> # User Gopu Govindaswamy <gopu at multicorewareinc.com>
> # Date 1378979612 -19800
> # Node ID 185918a342b05a9e420bcaeccc9b286a988c17ea
> # Parent  7be0ceae34e059849737050c52a326becd8bbf1a
> Encoder: Removed Code Duplication and made the common function for nal data extraction

Perhaps:

    Encoder: Factor out duplicated code NAL data extraction

>      void configure(x265_param_t *param);
>      void determineLevelAndProfile(x265_param_t *param);
> +    void x265_extract_naldata(AccessUnit &au, size_t &nalcount);

Perhaps I am mistaken, but I thought the x265_ function prefix was
only for the public C API?

> +        size_t nalcount;
> +        encoder->x265_extract_naldata( au, nalcount);

Nit: Accidental whitespace;

> +        size_t nalcount;
> +        encoder->x265_extract_naldata( au, nalcount);

Ditto.

> +void x265_t::x265_extract_naldata( AccessUnit &au, size_t &nalcount)

Ditto

Rest is OK.

- Derek


More information about the x265-devel mailing list