[x265] [PATCH] Encoder: Removed Code Duplication and made the common function for nal data extraction

Steve Borho steve at borho.org
Thu Sep 12 12:22:32 CEST 2013


On Thu, Sep 12, 2013 at 5:03 AM, Derek Buitenhuis <
derek.buitenhuis at gmail.com> wrote:

> On 9/12/2013 10:56 AM, Gopu Govindaswamy wrote:
> > # HG changeset patch
> > # User Gopu Govindaswamy <gopu at multicorewareinc.com>
> > # Date 1378979612 -19800
> > # Node ID 185918a342b05a9e420bcaeccc9b286a988c17ea
> > # Parent  7be0ceae34e059849737050c52a326becd8bbf1a
> > Encoder: Removed Code Duplication and made the common function for nal
> data extraction
>
> Perhaps:
>
>     Encoder: Factor out duplicated code NAL data extraction
>
> >      void configure(x265_param_t *param);
> >      void determineLevelAndProfile(x265_param_t *param);
> > +    void x265_extract_naldata(AccessUnit &au, size_t &nalcount);
>
> Perhaps I am mistaken, but I thought the x265_ function prefix was
> only for the public C API?
>

Nope, you are correct.  We only use x265_ prefix on the public C API where
we have to avoid name conflicts.  Internally, we use an x265 namespace,
though there are a few functions in common.h that use the prefix because
they were directly ported from x264, or if they didn't have a prefix they
might conflict with system symbols (x265_mdate, x265_log, X265_MIN, etc)

--
Steve Borho
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.videolan.org/pipermail/x265-devel/attachments/20130912/172e8e83/attachment.html>


More information about the x265-devel mailing list