[x265] [PATCH 0/2] Add Neon impl of findPosFirstLast

Micro Daryl Robles microdaryl.robles at arm.com
Tue Apr 8 15:13:29 UTC 2025


Hi,

This patch series adds a Neon intrinsic implementation of
findPosFirstLast.

Also, we are submitting a proposal to rename CLZ/CTZ to BSR/BSF, as the
current CLZ macro does not actually count leading zeros. Instead, it
returns the index of the highest set bit, which aligns with the behavior
of BSR.

This series is based on the master branch.

Many thanks,
Micro

Micro Daryl Robles (2):
  AArch64: Add Neon implementation of findPosFirstLast
  Rename CLZ/CTZ to BSR/BSF

 source/common/aarch64/dct-prim.cpp  | 55 ++++++++++++++++++++++++++++-
 source/common/aarch64/dct-prim.h    |  2 +-
 source/common/bitstream.cpp         |  2 +-
 source/common/dct.cpp               |  4 +--
 source/common/ppc/dct_altivec.cpp   |  2 +-
 source/common/quant.cpp             |  8 ++---
 source/common/threading.h           | 18 ++++++----
 source/common/threadpool.cpp        | 10 +++---
 source/common/wavefront.cpp         |  2 +-
 source/common/x86/pixel-util8.asm   |  4 +--
 source/encoder/entropy.cpp          | 10 +++---
 source/encoder/frameencoder.cpp     |  4 +--
 source/encoder/slicetype.cpp        |  2 +-
 source/encoder/weightPrediction.cpp |  2 +-
 source/test/pixelharness.cpp        | 12 +++++--
 15 files changed, 102 insertions(+), 35 deletions(-)

-- 
2.34.1



More information about the x265-devel mailing list